How to resolve the "License is invalid" issue when activating license in VS2017

Applies to 
  • GhostDoc v5.5 or newer
  • CodeIt.Right v3.1 or newer

Symptoms

  • When activating license code in VSIX in VS2017 receive the "License is invalid" message

Cause

When you install our product(s) in VS2017 using VSIX package, the VSIX installer does not remove the older MSI deployed version, being a technology not compatible with MSI.

Having both MSI-deployed and VSIX-deployed copies of the product creates conflict in the licensing assembly which results in the issue validating the license and the "License is invalid" message.

Solution

The solution is to uninstall the MSI-deployed version through Control Panel -> Programs and Features and after that, you will be able to activate your license in Visual Studio.

Additional Information