GhostDoc v2018.2.19030 VS2017 VSIX will not load
Problem reported by scott findlay - February 22 at 9:56 AM
Resolved
Hello, I'm having trouble loading the GhostDoc VSIX into visual studio.
- GhostDoc is not installed under program files.
- Using VS2017 Pro 15.7.3
- .Net 4.7.03190
 
Trying to install the GhostDoc v2018.2.19030 VSIX.
Extension installs but when VS is started an error appears, "GhostDoc Pro package did not load correctly". When I check the VS log the relevant error is:
 
Still unable to load MEF component DLL: Could not load file or assembly 'Microsoft.VisualStudio.Threading, Version=15.8.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
 
For package: SubMain.GhostDoc.Package.clr4.6.dll
 
I have tried uninstalling and rebooting etc but same error each time.
 
Cheers,
Scott

2 Replies

Reply to Thread
0
Misha Zhutov Replied
Employee Post
Hi Scott, 
 
Thank you for reporting that. As a workaround please uninstall VSIX and install EXE version of GhostDoc.
 
0
Serge B. Replied
Employee Post
This issue is being fixed right now.
 
Thanks for your patience!
Serge Baranovsky
SubMain Software
(800) 936-2134

Reply to Thread