XXXX.sln.ghostdoc.xml file is not generating locally
Question asked by atul rajaram phaatk - January 23 at 2:00 AM
Answered
I have install GhostDoc Enterprise locally & trying to generate Help file for sample web project in ASP.Net MVC using command line.
It is not generating XXXX.sl.ghostdoc.xml file automatically so it is giving error like "No code elements found to include into the help documentation. Please make sure
 you are using correct help configuration and check the Scope parameters." while running command. so I have created XXXX.sln.ghostdoc.xml manually by taking reference of sample project ClassLibrary1 from
https://community.submain.com/blogs/tutorials/archive/2014/03/05/conceptual-content-adding-custom-content-to-api-documentation-created-with-ghostdoc.aspx
I dont wish to add Conceptual Content page so I kept ConceptualContent tag empty in XXXX.sl.ghostdoc.xml.
so when I run command -> SubMain.GhostDoc.Cmd.exe /solution:"Sample.sln" /helpConfiguration:"HelpFile" /projectconfiguration:"Debug" 
It is showing building help documentation & done on command prompt but Help file is not present in Help folder of project.
Is I missed something? 
I just want to create same Help doc file when we click on "Build Help Documentation" from Tools menu in Visual Studio 17 by using command line so that I can create Help file on Build Servers.
Attached the file XXXX.sln.ghostdoc.xmlGhostDocHelloWorld.sln.GhostDoc.xml
 

1 Reply

Reply to Thread
0
Misha Zhutov Replied
Employee Post Marked As Answer
Hello, 
You don't need to create <solution>.sln.GhostDoc.xml file manually. You need to open your project in Visual Studio, open Tools->GhostDoc->Build Help Documentation and configure all options.
The file you provided looks good. What is your project name? Is it "GhostDocHelloWorld"?
You can send us your test project to support@submain.com and we will be able to help you.

Reply to Thread