Keyboard shortcut CTRL + SHIFT + D (Document this) doesn't work
Problem reported by Luis de Santiago Buey - June 19 at 12:00 AM
Resolved
I am using VS2017 Pro (15.7.4), with GhostDoc Community. Some days (it doesn't happen always), when I use the keyboard shortcut CTRL + SHITF + D, it won't work. If that happens, it won't work through all the VS session. If I restart again, maybe it works, maybe it doesn't. If it works, it will work through the VS session.
 
If I go through the menu, it works all right.
 
If I go and reassign the shortcut (Tools > GhostDoc > ReAssign Shortcut), it still doesn't work.
 
I believe this happens since some resharper upgrade that happened like 2 months ago

2 Replies

Reply to Thread
0
Hello Misha. Thanks for your comments
 
Weird. When I go to Visual Studio->Tools->Options->Environment->Keyboard and press CTRL+SHIFT+D, VS doesn't recognize the shortcut and show me nothing. If I press CTRL+D, it finds a shortcut, if I press CTRL + SHIFT + another letter (F, for example), it finds the shortcut. Only not with CTRL + SHIFT + D

Which says it should be correctly configured.
 
 
The fact that it looks like VS doesn't receive the shortcut looks promising.
 
Used Spy++ to capture keyboard events, and I see that this WM_SHORTCUT event has been sent to Catlight, an application to check the status of builds, which I believe is built on electron. And it looks like it has the chrome dev tools open.
Then I close the Catlight window and the shortcut works perfectly.
So mystery solved
Thanks a huge lot :)
 
 
0
Misha Zhutov Replied
Employee Post
Thank you for the update.

Reply to Thread