GhostDoc XML comments in .hpp file
Problem reported by Christian Dufter - May 25 at 5:46 AM
Being Fixed
I stumbled accross a problem today. I started a new project in Visual Studio 2017 in C++. This time I wanted to change my coding conventions a bit and name my header files as ".hpp" to distinct them as C++ headers.

The problem I have now, is whenever I want to add an XML comment (via /// or shortcut or context menu), GhostDoc puts the comment in the .cpp file, not in the header. If I name the header files ".h" again, it puts the comments in the header, where I want them to be.

I wasn't able to find any option where I could configure the wished behaviour and coudn't find any open forum thread for this topic.

1 Reply

Reply to Thread
0
Serge B. Replied
Employee Post
Hi Christian,
 
You are correct, you are the first one to report this. We missed the .hpp extension for the header files and we will add it to the list.
 
Thanks!
Serge Baranovsky
SubMain Software
(800) 936-2134

Reply to Thread