Possible Performance Problem
Problem reported by MD - November 12 at 3:04 AM
Resolved
Since installing GhostDoc, I've noticed some hitching in the text editor as I type.  Visual Studio has also noticed and provided an impacted performance toast notification under the title bar.

However, it is saying it is another extension I have installed:
I did file a bug with JetBrains, along with a timeline capture, and they are stating that GhostDoc is in the traces here:


So, thought I would mention it to see if there is anything further to consider on my side, and/or if you are aware of this issue.

10 Replies

Reply to Thread
0
Misha Zhutov Replied
Employee Post
The "SubMain.GhostDoc.Gui.Dialogs.WaitDialogForm.c5ae017640afd2395c21c5fb745bc4670" method works only when you run "Open Comment Editor" or "Document File" where waiting window (attached) is visible.
Also, GhostDoc does not affect the typing performance if Enable Documentation Hints in Editor is disabled.Screenshot_20191112_3.png
0
MD Replied
I do have Enable Documentation Hints in Editor is disabled.  In the case of the WaitDialogForm, it was not visibly open, yet I was experiencing hitches while typing.  Perhaps there is a bug where the window is actually open but not visible?

The other thought are the GhostDoc Windows.  I currently have them all open, with Comment Preview being one of them.  Perhaps that is causing some problems as well?

I will keep a lookout for this and let you know of any additional findings that I encounter.
0
Misha Zhutov Replied
Employee Post
I am really suspicious about JetBrains conclusion. We always close (not hide!) the WaitDialogForm and not using it when typing. I have no idea how they measure performance impact - maybe, they do it for some time period?

Also, enabled spell checker (Enable Spell Checker in GhostDoc menu) and real time preview (Realtime preview button on Comment Preview toolwindow) may have an impact on typing.
0
MD Replied
Hah... to be sure, the visibility guess was mine and not JB.

I have closed the Comment Preview window altogether and never did turn on spell check as that is already handled by ReSharper.

However, notifications still persist, and they point to ReSharper.  I also just noticed this as well, a new feature of Visual Studio:


So it seems both are at fault here.  I am beginning to suspect perhaps a rough pairing between these two extensions somewhere...
0
MD Replied
I can confirm that after disabling GhostDoc the hitching and performance toast notifications go away.  So, not sure if it's because they are using the same resource or something, but it would seem these two do not get along together ATM. 😆

EDIT: Of course, as soon as I post this, I get a notification toast in Visual Studio! LOL.  There might be several issues occurring here: one is that ReSharper's xml documentation handling might be suffering some issues.  The other is that there might be an issue with the combination of GhostDoc and ReSharper.  In particular, pressing "///" incurs a massive and noticeable delay.

DOUBLE EDIT: Of course, right after I post the above edit, the JetBrains team also commented that they now see both GhostDoc *and* ReSharper issues after sending a larger performance timeline to them:
1
Misha Zhutov Replied
Employee Post
We will review all possible typing impacts with our development team and get back to you shortly.
1
Misha Zhutov Replied
Employee Post Marked As Resolution
Please download and install the interim build from here
We fixed /// typing behavior there.

Also, please uncheck the following options:
1. Tools->GhostDoc Pro->Options->Spelling Options -> Check spelling as you type
2. Tools->GhostDoc Pro->Options->Maintenance -> Show Documentation Hints in Editor
3. Tools->GhostDoc Pro->Options->General -> Real-time Preview
4. Tools->GhostDoc Pro->Options->General -> Generate GhostDoc XML comments for /// (C#) and ''' (VB)
and click OK

Then, try to type and see typing value in the Visual Studio Performance Manager.
Please let us know if it helps.

0
MD Replied
Cool!  Looks like "Generate GhostDoc XML comments for /// (C#) and ''' (VB) " was the culprit... documentation gets generated pretty quick now, but isn't autogenerated, obviously.  That works for me as I would like to use /// to generate and then CTRL-SHIFT-D to enact the editor to flesh it out.

FWIW, neither ReSharper nor GhostDoc shows up in the Performance Metrics > Typing with those settings turned off. 😲  I will monitor and update here if that changes, however.

BTW, I noticed this... should be "No Grouping" 😁

1
Misha Zhutov Replied
Employee Post
Thank you for the update. Yes, we have fixed the misspelling word.
0
MD Replied
OK great... thank you for your patience!  FWIW, we're finding that simply holding down the spacebar followed by holding down CTRL-Z (with ReSharper uninstalled -- !) is causing massive hitching and delays in Visual Studio 16.3.9, which was just released recently.

So, a weird set of coincidences of having installed 16.3.9, the latest ReSharper, and GhostDoc.  I've marked your suggestions for improving performance on GhostDoc's side as it looks like there are much bigger problems in the land of Visual Studio right now. 😆

Thanks again for having the patience in catching me up to date with GhostDoc... hopefully someone else will benefit from this, too. 👍

Reply to Thread